Flummoxed by IT: Scala UnsupportedClassVersionError unsupported major.minor version